Why do I need an AIX upgrade for Eclipse 8.6.9?

The application server portion of Eclipse 8.6.9 requires JBoss 5.1 and Java 6. The IBM Java 6 SDK requires the following minimum levels of AIX:

Java 6 32-bit Java 6 64-bit
Minimum AIX level supported – 5.1 N/A N/A
Minimum AIX level supported – 5.2 N/A N/A
Minimum AIX level supported – 5.3 5300-07 (APAR IZ07976) 5300-07 (APAR IZ07976)
Minimum AIX level supported – 6.1 6100-GOLD 6100-GOLD
Minimum AIX level supported – 7.1 7100-GOLD 7100-GOLD
End of Service 30 Nov 2017 30 Nov 2017

Source: http://www.ibm.com/developerworks/java/jdk/aix/service.html

If you follow the recommended best practices for keeping your AIX server up to date, you are already on a supported version of AIX.